Harrison Consoles Mixbus
+

Mixbus, Séquenceur généraliste de la marque Harrison Consoles.

Comparateur de prix
Petites annonces
  • J'aime
  • Tweet
  • Partager
  • Mail

Mixbus & Compensation de la latence

 
AuteursMessages

r_tbo

offline
r_tbo
6 posts au compteur
Nouvel AFfilié

1 Posté le 15/03/2011 à 15:31:08

Bonjour,

J'ai un problème de latence lors de l'enregistrement avec MixBus . Je pense que le problème vient de jack et d'une erreur de compensation de latence.

Le test et les symptômes :

J'ai rebouclé une sortie (OUT3) vers l'une des entrées (IN3) et mesuré l'écart entre les 2 signaux.

Premier constat : le décalage n'est pas tout à fait le même suivant que jack soit lancé par jackpilot ou par MHB ???? Bizarre non ?  icon_exorbite.gif

Deuxième constat : avec un réglage de latence à 256 echantillons j'ai des décalages de l'ordre de 7 ms entre les fichiers. SI j'ai un réglage à 512 échantillons, l'écart est de 25 ms. Cela me semble beaucoup non ? (avec un vieux Cubase SX1 sous powerbook G4, je suis à beaucoup moins !!).

Avez vous des idées ?

Merci d'avance

Ma config : motu 828mkII / MacBook Pro / HMB 1.5.1 / Jack OSX 0.87

 

 

[ Dernière édition du message le 15/03/2011 à 22:05:59 ]

r_tbo

offline
r_tbo
6 posts au compteur
Nouvel AFfilié

2 Posté le 17/03/2011 à 13:37:59

Je me réponds. Après un mail à Harrisson, j'ai eu la réponse suivante (et rapide) de Ben Loftis (développeur de mixbus) :

Citation de Ben Loftis :

We have recently become aware of this bug and are working on a fix.

There are 2 temporary solutions:
1)  after recording, right-click on the regions and choose  " nudge
by capture offset "

2)  When launching Mixbus, in the Audio Setup dialog, choose
Advanced->Hardware Input Latency  and add your buffer size (256 or
512).  Note: you must always use the same buffer setting for this to
work.


I'm very sorry for this problem.  We hope to have a permanent
solution to this problem in an upcoming release.

 

 

Aucune des 2 solutions n'a marché pour moi :

- le décalage d'une durée correspondant au délai de capture, décalait trop les pistes (genre 2 ou 3 ms avant la piste source)

- pour la deuxième solution, pas moyen de rentrer la moindre donnée dans l'onglet "avancé" pour la config audio. (un Bug de GTK je suppose).

Donc,après analyse des log pour capter comment était lancé jack, j'ai ajouté -I 512 afin d'ajouter la donnée HARDWARE INPUT LATENCY (cf doc de jackd) :

/usr/local/bin/jackdmp -p 512 -R -P 10 -d coreaudio -r 44100 -p 512 -I 512 -d com_motu_driver_FWA_Engine:0aeb401000

Pas d'amélioration de la latence. J'ai donc tenté -I 1024 et là, c'est beaucoup mieux mais pas parfait. -I 1095 semble être pas mal. Je vais finalisé ça dans les jours à venir pour avoir une synchro à l'échantillon prés.

Pour info, Ardour n'a pas ce bug.

Revenir en haut de la page