Comparateur de prix
Petites annonces
  • J'aime
  • Tweet
  • Mail

Configurer DTXpress sur EZdrummer // Problème avec mon Hi Hat control ...

 
  • Signaler un abus
AuteursMessages

Power Bibi

membre non connecté
Power Bibi
527 posts au compteur
Posteur AFfolé

Score contributif : 373

1 Posté le 15/05/2011 à 15:34:11Lien direct vers ce postSignaler un abus
Bonjour,

Voilà, ca fait quelques temps que je galère à utiliser ma DTXpress sur mon PC et ca serait vraiment super si quelqu'un pouvait m'expliquer 2/3 trucs

Je souhaite simplement la brancher en midi pour contrôler EZ Drummer.
Je passe le midi (OUt) de la DTXpress vers le midi (in) de ma carte son Novation NIO 2/4.
J'utilise Ableton Live 8 avec Ezdrummer en VST.

Mais voilà ! Je reçois bien des données midi sur Ezdrummer, mais uniquement lorsque je joue d'abord la pédale HI HAT control de la DTX !

En pratique, lorsque je joue le Hi hat control puis rapidement sur la caisse claire (par exemple), j'entends le son de la caisse claire sur Ezdrummer.
Par contre, si je retape fr nouveau sur la caisse claire (sans le hi hat control avant), aucun son ne sort.
C'est comme si le Hi Hat servait de contrôleur et qu'il autorisait à faire "sonner" un pad seulement si on l'a enclenché avant...

J'ai trifouillé le menu Util de la DTXpress, j'ai tenté quelques modifs sans succès, mais j' n'y comprends rien...

Aidez moi, je vous en serai éternellement reconnaissant!!! C'est rageant d'être si près du but et de ne pas y arriver !! :boire:

Merci ;-)

http://www.facebook.com/ElectricFud

http://www.facebook.com/LesBridget

Azz972

membre non connecté
Azz972
27 posts au compteur
Nouvel AFfilié

Score contributif : 120

2 Posté le 15/05/2011 à 18:42:06Lien direct vers ce postSignaler un abus

Salut,

 

As tu vérifié que tu utilises bien un jack stéréo pour ton hi-hat?

 

Fred

http://azz.free.fr

 

[ Dernière édition du message le 15/05/2011 à 18:43:12 ]

Power Bibi

membre non connecté
Power Bibi
527 posts au compteur
Posteur AFfolé

Score contributif : 373

3 Posté le 15/05/2011 à 18:57:07Lien direct vers ce postSignaler un abus
Oui, il s'agit bien d'un jack stereo...

Merci pour ton intervention !

http://www.facebook.com/ElectricFud

http://www.facebook.com/LesBridget

MGOMKD

membre non connecté
MGOMKD
58 posts au compteur
Posteur AFfranchi

Score contributif : 142

4 Posté le 15/05/2011 à 20:44:14Lien direct vers ce postSignaler un abus
Salut,

Voici une éventuelle possibilité:
Si mes souvenirs sont bons le Hi Hat disposent de 2 voies Midi.
Il faudrait vérifier que le numéro de voie assigné au Hi Hat ouvert, ne soit pas le même que la caisse claire.

De plus les évènements Midi, et notamment le déclenchement de note NoteOn et le relâchement de note NoteOff doivent bien être réglés afin d'éviter les conflits. Je ne connais pas EZdrummer mais pour ma part j'ai travaillé sur Cubase et pour lequel il est facile d'éditer la Drum Map et ce pour chaque Kit du Module DTXpress.

Comme le dit également Azz972 que ton câble Jack soit bien en stéréo et qu'il ne soit pas endommagé.

En tout cas avant de "Trifouiller" dans les interfaces Midi, bien vérifier tous les branchements 1 à 1 que ce soit sur le PC, la carte son ou le module.

Courage nous trouverons la solution.

Power Bibi

membre non connecté
Power Bibi
527 posts au compteur
Posteur AFfolé

Score contributif : 373

5 Posté le 16/05/2011 à 00:32:25Lien direct vers ce postSignaler un abus
Bon, j'ai essayé de changer les numéros de voie sur la batterie, de changer les notes également, etc... malheureusement, je me retrouve toujours avec le même problème.

Je n'arrive pas à faire sonner plusieurs fois le même tom sauf si je garde le pied sur mon Hi hat et que je l'actionne (très) régulièrement :(
Mais dans ce cas, en gardant la cadence je peux jouer sur tous les pads et même enregistrer cela sur Ableton... Et je vois bien les notes midi de ce que j'ai enregistré avec...

C'est bizarre. En fait, ma pédale de Hi Hat permettrait à l'autre note midi de passer à travers et faire sonner le ou les pads désiré(s)...
C'est trop esotherique le midi pour moi en fait :|

Pourtant il y a surement un truc tout bête :pleure:

Citation :
Courage nous trouverons la solution.

:-p :bravo:

Merci a vous ! ;-)

http://www.facebook.com/ElectricFud

http://www.facebook.com/LesBridget

Power Bibi

membre non connecté
Power Bibi
527 posts au compteur
Posteur AFfolé

Score contributif : 373

6 Posté le 28/05/2011 à 13:39:20Lien direct vers ce postSignaler un abus
Bon, je galère toujours avec le paramétrage midi de ma batterie...

J'ai quand même pu assigner des sons à chaque pad que je joue.
Désormais, je n'ai plus besoin d'activer ma hi hat control avant de jouer (et donc de faire sonner) mon pad.

Par contre, je rencontre encore un problème similaire :
- Lorsque je joue un fois le pad 1 , j'ai du son
- Lorsque je rejoue ce pad 1 à la suite, je n'en ai plus
- Il faut alors que je joue un autre pad (par ex. le 2) avant de pouvoir faire sonner à nouveau le pad 1

J'ai téléchargé un programme : Midi Monitor ( http://obds.free.fr/midimon/indexfr.htm )

Il me donne des indications sur les signaux midi qu'il reçoit...

Voici ce que ca donne

- Lorsque je tape une première fois sur le Pad 1 :

95 1F 7B Note On G0 (sol0) Velocity: 123 Channel 6
95 1F 00 Note On G0 (sol0) Velocity: 0 Channel 6

- Lorsque je tape une seconde fois sur le pad 2, il m'indique :

FE 1F 00 Unknow Common Unused Unused Unused
FE 68 00 Unknow Common Unused Unused Unused
FE 1F 00 Unknow Common Unused Unused Unused

- Et si j'enchaine le pad 1 puis le pad 2 :

98 30 7F Note On C2 (do2) Velocity: 127 Channel 9
98 30 00 Note On C2 (do2) Velocity: 0 Channel 9
95 1F 47 Note On G0 (sol0) Velocity: 71 Channel 6
95 1F 00 Note On G0 (sol0) Velocity: 0 Channel 6

- Si j'enchaine le pad 1, puis le pad 2 puis le pad 2 une seconde fois :

95 1F 7F Note On G0 (sol0) Velocity: 127 Channel 6
98 30 69 Note On C2 (do2) Velocity: 105 Channel 9
95 1F 00 Note On G0 (sol0) Velocity: 0 Channel 6
98 30 00 Note On C2 (do2) Velocity: 0 Channel 9
95 1F 5E Note On G0 (sol0) Velocity: 94 Channel 6
FE 1F 00 Unknow Common Unused Unused Unused


Bref... je pense qu'il y a un problème lorsque le contrôle du pad pass en Unknow common, c'est comme si cela désactivait la possibilité de rejouer ce pad...

Quelqu'un aurait une idée de ce que je pourrai tenter ?

Merci :boire:

http://www.facebook.com/ElectricFud

http://www.facebook.com/LesBridget

MGOMKD

membre non connecté
MGOMKD
58 posts au compteur
Posteur AFfranchi

Score contributif : 142

7 Posté le 28/05/2011 à 15:00:01Lien direct vers ce postSignaler un abus
Je me pose une question?

Avec quelle interface as-tu branché ton DTXPress vers ton PC?

Personnellement je possède l'interface UM-1G de chez Cakewalk.

Sur cette interface, comme la plupart, il y a une fonction MIDI-THRU.
Cette fonction permet de perpétuer le signal vers d'autre appareils. Ainsi lorsque tu tapes sur un pad du module, le DTXPress envoie un signal par le Midi-out de l'interface, puis le signal est traité par le logiciel courant et il revient dans le Midi-In de l'interface et finalement dans le DTXPress. C'est là que, parfois le problème surgit.

En effet si la fonction MIDI-THRU est activée, le DTXPress envoie et reçoit son propre signal indéfiniment(Boucle), sauf que la mémoire tampon pour le canal Midi en cour sature à un moment donné.

Il faut également vérifier que l'application elle même n'ait pas cette fonction (Notamment Cubase dispose de cette fonction).


l'analyse des indications de ta batterie:

Chaque fois que tu frappes tu as 2 lignes et c'est tout à fait normal.

On a pour la 1ère ligne:
- Le code Hexadécimal de la note.
- L’événement midi de la note soit Note On (Déclenchement de note)
- Le Numéro de Note de la Drum Map.
- La vélocité allant dont la valeur de 0 à 127 (Valeur de frappe)
- Le canal midi attribué au pad.

On a pour la 2nde ligne:
- Idem que la 1ère à l'exception de la vélocité toujours égale à 0

En théorie le relâchement de note pour tout appareil midi s'appelle Note Off sauf que pour une batterie le relâchement de note ne peut être contrôlé c'est pourquoi dans le protocole du DTXPress l’événement Note On + vélocité=0 est envoyé après chaque frappe. De plus lorsque l'on regarde les caractéristiques Midi dans le manuel on se rend compte que le Note Off n'est pas géré ni en émission et ni en réception.

Voici donc une autre piste.

Tiens nous au courant.

@+

Power Bibi

membre non connecté
Power Bibi
527 posts au compteur
Posteur AFfolé

Score contributif : 373

8 Posté le 28/05/2011 à 17:23:43Lien direct vers ce postSignaler un abus
Merci de m'aider ;-)

L'interface utilisée est une Novation NIO 2/4
Pour la question du Midi Thru, je n'ai d'option particulière sur la carton son et pas d'indication comme çà sur la DTXpress... Mais si j'ai bien compris, c'est quand on branche le Midi out DTX sur le Midi In de la carte son puis du out de la carte son vers le in de la DTXpress ? parce que je n'utilise que le midi out DTXpress vers Midi in Novation ...

Citation :
De plus lorsque l'on regarde les caractéristiques Midi dans le manuel on se rend compte que le Note Off n'est pas géré ni en émission et ni en réception.

Tu penses que c'est cuit alors ? :-(

Merci,

http://www.facebook.com/ElectricFud

http://www.facebook.com/LesBridget

MGOMKD

membre non connecté
MGOMKD
58 posts au compteur
Posteur AFfranchi

Score contributif : 142

9 Posté le 28/05/2011 à 19:50:38Lien direct vers ce postSignaler un abus
Non pas du tout ce n'est pas cuit. Mais il faut toujours brancher les deux câbles car les appareils s'envoient des informations.

Power Bibi

membre non connecté
Power Bibi
527 posts au compteur
Posteur AFfolé

Score contributif : 373

10 Posté le 29/05/2011 à 00:14:45Lien direct vers ce postSignaler un abus
Ok !
J'avais pourtant cru lire que ca n'était pas nécessaire

Bon, je m'achète un autre câble midi et je te tiens au jus !
Merci encore ;-)

http://www.facebook.com/ElectricFud

http://www.facebook.com/LesBridget

Revenir en haut de la page