• J'aime
  • Tweet
  • Partager
  • Mail

Solution au problème Hercules RMX et sources externes line/phono

 
AuteursMessages

xeyou

offline
xeyou
1 post au compteur
Nouvel AFfilié

1 Posté le 28/02/2012 à 16:53:21
Bonjour,

D'après mes recherches google, beaucoup de personnes n'arrivent pas à utiliser les sources externes (platines vinyl ou autres) avec leur RMX (et VirtualDJ). J'avais le même problème, et je n'ai pas trouvé la solution complète sur le web.

J'ai néanmoins réussi à résoudre le problème, et vu que ça m'a vraiment pris la tête, je prends le temps d'expliquer la solution que j'ai trouvé (avec VirtualDJ Pro, en l'occurence).

Donc, je souhaitais connecter mes platines vinyl, mais je n'avais pas de son quand j'appuyais sur le bouton Source de la console (à noter : selon les cas, ce silence peut être remplacé par un gros buzz des plus désagréables). Ceci pour la bonne raison que le bouton Source, par défaut, n'était pas programmé pour cette tâche, mais pour connecter les vinyls timecode.

Donc, voici la solution à mon problème (je ne peux rien pour vous si vous avez un problème différent, désolé). Dans un premier temps, après avoir lancé VirtualDJ et branché la console, il faut s'occuper de la configuration audio, premier onglet dans "Config" (en haut à droite dans VirtualDJ).

entrées : line-in (ceci permet de voir le spectre audio de la source externe)
sortie : single output (ou autre)
carte son : Hercules RMX, en cochant la case "Eq" juste à côté

Mais attention, ceci n'est pas suffisant !

Dans "Config", il faut ensuite aller dans l'onglet "Mappeurs". Le cadre à gauche contient le mapping de la console, c'est-à-dire la liste du rôle de chaque touche de votre RMX. Si vous avez le même problème que moi, dans cette liste, la key "source" est associée à l'action "bypass timecode". C'est ce simple détail qui vous empêche d'utiliser vos sources externes : quand vous appuyez sur "Source", la console s'attend à recevoir sur cette entrée le signal d'un vinyl timecode, et non pas un signal classique de platine vinyl ou autre !

Dans cette liste, il faut donc sélectionner la ligne key-source action-bypass timecode et la supprimer, avec le bouton "Poubelle" sous la liste. Désormais, vos boutons "Source 1" et "Source 2" ne sont plus affectés à aucune fonction. Il faut donc les affecter à la sélection des sources externes.

Toujours dans ce même onglet "Mappeurs", sous la liste key/action, vous cliquez sur la case "+" en vert, "ajouter une nouvelle key" (c'est à dire, définir l'action d'une nouvelle touche de votre console RMX). Ensuite, dans la partie droite de l'onglet, vous allez définir cette nouvelle key :

- sur "key-learn" : tapez SOURCE (en majuscule, pour choisir le bouton Source de votre console)
- sur "action-learn" : tapez linein (en minuscule, pour choisir l'action à attribuer au bouton choisi)
- cliquez sur OK

Et voilà. Désormais, le bouton "SOURCE" est affecté à l'action "linein". En clair, les boutons Source 1 et Source 2 de votre RMX ont enfin la fonction que vous souhaitiez : basculer vers l'entrée externe !

Evidemment, vous aurez remarqué le commutateur phono/line sur chaque entrée. Pour ceux qui l'ignorent, pour connecter une platine vinyl, utilisez la position "phono" (tapez "préampli RIAA" dans google pour plus d'infos). Pour toute autre source (platine CD, lecteur mp3, mixette, etc), utilisez la position "line".

C'est tout. Vous pouvez désormais mixer vos sources externes avec vos mp3, dans tous les sens ! Dans mon cas, au début, il y a eu quelques légers bugs, mais c'était juste le temps que le logiciel et la console se fassent à la nouvelle config.

J'espère que mon message vous sera utile. S'il ne vous permet pas de régler votre problème, c'est qu'il est probablement différent du mien. Le point clé ici, c'est vraiment de bien comprendre que le bouton "Source" n'est pas programmé pour l'action que l'on pense, et qu'il faut donc le reprogrammer. Ça parait tout bête après coup, mais quand on sait pas...

[ Dernière édition du message le 28/02/2012 à 16:54:27 ]

pinou

offline
pinou
1896 posts au compteur
AFicionado

Score contributif : 422

2 Posté le 15/06/2012 à 12:00:54
Un gros merci. J'essaye ça sous peu.

Vends ampli basse Carlsbro Bass Booster Combo 85 Watts - 80 E

pinou

offline
pinou
1896 posts au compteur
AFicionado

Score contributif : 422

3 Posté le 16/06/2012 à 16:21:41
Yes ! Ca marche !

Un gros bisou sur la fesse droite, xeyou. Ca faisait un bon moment que je me prenait la tête sans résultats !

Encore merci !

Vends ampli basse Carlsbro Bass Booster Combo 85 Watts - 80 E

Pron

offline
Pron
5 posts au compteur
Nouvel AFfilié

4 Posté le 09/11/2012 à 16:46:30
:aime:

Merciciciciicicicicicicicici.........

Vraiment génial.

punkboy202

offline
punkboy202
56 posts au compteur
Posteur AFfranchi

5 Posté le 25/09/2016 à 14:14:56
salut à tous,

j'ai pas tout à fais ce problème mais je suis sous Xubuntu 14.04 j'utilises la hercules RMX comme carte son pour lire des fichiers audio uniquement -je ne mixe pas-, je souhaites à présent utilisé les entrées de la console pour la lecture de cd's audio à l'aide d'un lecteur de cd de salon, dans les menus Pulseaudio il apparaît que le son du lecteur cd sort effectivement mais je n'ais pas de son sur la chaîne hifi, quelqu'un sait il comment faire ? je ne souhaites pas utilisé le soft "équivalent" à virtual dj pour linux qui se nomme "Mixxx" je crois... est-ce donc absolument nécessaire ? je ne crois pas par il y'a quelques années il me semble que j'utilisé les entrées de la RMX mais sous windows sans trop de soucis et sans utilisé virtual DJ, mais je ne suis plus trés sûr car il se peut effectivement qu'il faut activé d'une façon ou d'une autre un des boutons "source" situé sur la console...

y'a t il une manipulation à effectué pour que le son sorte dans Xubunt-- LINUX?

MERCI.

Anonyme

offline
hyperwolf
Ce membre n'existe plus

Score contributif : 244

6 Posté le 26/09/2016 à 03:00:21
Beau geste de ta part d'avoir partagé le fix avec les autres, dude! :bravo:

Made In Breizh

offline
Made In Breizh
2666 posts au compteur
Squatteur d'AF

Score contributif : 477

7 Posté le 26/09/2016 à 10:00:18
Bonjour punkboy202,

Je n'ai pas Ubuntu et Pulseaudio, donc je peux pas répondre exactement à ce cas précis, mais ce que vous écrivez sur le bouton source me fait penser qu'il faut repréciser un détail :
- les contrôles de la DJ Console Rmx sont des contrôles MIDI, pas des commande de table de mixage analogique,
- les seules commandes analogiques sur la DJ Console Rmx sont l'activation du microphone, les commutateurs phono/ligne des entrées audio, et le volume casque,
- donc les boutons Sources, volume fader, equalisation etc... sont inactifs si le logiciel que vous utilisez ne comprend pas ces commandes MIDI,
ce qui signifie que, sur votre logiciel qui n'est pas mixage, pour faire passer l'audio par la Rmx d'une entrée vers une sortie, c'est dans les menus du logiciel que vous devez router l'audio et régler son niveau de sortie, puisque les contrôles sur la surface de la Rmx ne sont pas activés dans ce logiciel.

punkboy202

offline
punkboy202
56 posts au compteur
Posteur AFfranchi

8 Posté le 26/09/2016 à 11:23:39
Merci Made In Breizh d'avoir pris le temps pour cette réponse... effectivement là ou je coince c'est que le signal audio du lecteur cd est bien diffusé au travers pulseaudio -dans l'onglet "entrées" de celui-ci- il y'a bien un indicateur de signal audio qui est en "mouvement". donc la question que je me pose est comment le son qui est entrée parvient à la sortie, ça serait en simultanée via port usb et rca ? je pense que si j'utilise un soft type audacity le son sortira, mais je ne souhaites pas utilisé de soft... je me disais donc que le sons du cd sortirai sans ouvrir de logiciel voire même si j'ai clementine qui lit un fichier audio le son sortira en même temps celui provenant du cd et du lecteur audio clementine ... je suis un peu pommé :) :) :) aprés c pas urgent mais bon ça m'apporterai plus d'entrées audio ... et il est vrai que la configuration du son sur linux n'est pas des plus aisée en général.. mais je prendrai le temps de brancher la rmx sur win7 pour saisir comment cela fonctionne... hélas je n'ais pas le manuel de la rmx avec moi, donc ... je vais voir sur le net si je le trouves...

en attendant si quelqu'un a une réponse je suis preneur...
voilà..

merci encore...

Made In Breizh

offline
Made In Breizh
2666 posts au compteur
Squatteur d'AF

Score contributif : 477

9 Posté le 26/09/2016 à 12:03:17
Il faut un logiciel audio pour activer un pass-through sur la Rmx.
Sous Mac et PC, le panneau de contrôle offre une option pour activer le pass-through de l'entrée 1-2 vers la sortie 1-2, mais il n'y a pas de panneau de contrôle sous Linux.
Cette option est Output 1-2 = USB Streaming + Line-in 1-2
https://s6.postimg.org/9ymxx08m9/Rmx_MIDI_Channel_1.png

Par défaut, la sortie 1-2 ne joue que le streaming USB, donc s'il n'y a pas de logiciel pour envoyer le son, il n'y a pas de son sur la sortie 1-2.

punkboy202

offline
punkboy202
56 posts au compteur
Posteur AFfranchi

10 Posté le 26/09/2016 à 12:23:42
ah merci ... encore , si quelqu'un sait ce qui peut se substitué au pass-through sous linux, merci , je vais regardé de mon côté...
Revenir en haut de la page